buildBaseGraph MethodStatic
- Exterior half edges have HalfEdgeMask.EXTERIOR
- All interior half edge around a facet have facetTag pointing to a facetProperties object for that facet.
- the facetOffsetProperties object has the simple facet normal.
- Each half edge has edgeTag pointing to to a sectorOffsetProperties object
- the sectorOffsetProperties has a copy of the facet normal.
buildBaseGraph(polyface: IndexedPolyface): undefined |
@returns graph
Parameter | Type | Description |
---|---|---|
polyface | IndexedPolyface |
Returns - undefined |
graph
Defined in
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.