createNormalComparison MethodStatic
Create a visitor for those mesh facets with normal in the same half-space as the given vector.
- For example, to visit the top facets of a tiled terrain mesh but skip the "skirt" facets, pass
compareVector = Vector3d.unitZ()
and a suitablesideAngle
tolerance. Note that this will also filter out interior facets that are nearly vertical, not just the "skirt" facets on the boundary.
createNormalComparison(mesh: IndexedPolyface | IndexedPolyfaceVisitor, compareVector: Vector3d..., sideAngle: Angle..., numWrap: number0): IndexedPolyfaceSubsetVisitor
Parameter | Type | Description |
---|---|---|
mesh | IndexedPolyface | IndexedPolyfaceVisitor | the mesh from which to select facets |
compareVector | Vector3d | vector to which to compare facet normals. The visitor will visit only those facets with normals in the same half-space as this vector. Default is 001. |
sideAngle | Angle | optional angular tolerance to filter the facets near the border between half-spaces. The visitor will not visit facets whose normals are nearly perpendicular to compareVector .Default is smallAngleRadians. |
numWrap | number | optional number of entries replicated in visitor arrays. Default is 0. |
Returns - IndexedPolyfaceSubsetVisitor
Defined in
- polyface/IndexedPolyfaceVisitor.ts Line 288
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.