HoleFillOptions Interface
Options carrier for fillSimpleHoles.
Properties
Name | Type | Description | |
---|---|---|---|
includeOriginalMesh | boolean | undefined | Requests that all content from the original mesh be copied to the mesh with filled holes. | |
maxEdgesAroundHole | number | undefined | Reject hole candidates if they have more than this number of edges. | |
maxPerimeter | number | undefined | Reject hole candidates if its boundary chain is longer than this limit. | |
upVector | Vector3d | undefined | Reject hole candidates if their orientation is not COUNTERCLOCKWISE around this vector. |
Defined in
- polyface/PolyfaceQuery.ts Line 151
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.