getColor Method
Get color interpolated from facet data.
getColor(facetColors?: number[], facetVertices?: IndexedXYZCollection, distanceTolerance: numberGeometry.smallMetricDistance): undefined | number
@returns cached color
Parameter | Type | Description |
---|---|---|
facetColors | number[] | used to compute the color cache |
facetVertices | IndexedXYZCollection | used to compute the barycentric coordinate cache |
distanceTolerance | number | used to compute the barycentric coordinate cache |
Returns - undefined | number
cached color
Defined in
- polyface/FacetLocationDetail.ts Line 470
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.