computeDisplacementRange Method
Compute the range of this channel's displacement values, if dataType is AuxChannelDataType.Vector.
computeDisplacementRange(scale: number1, result?: Range3d): Range3d
@returns The range encompassing all this channel's displacements scaled by scale
; or a null range if this channel does not contain displacements.
Parameter | Type | Description |
---|---|---|
scale | number | Scale by which to multiply each displacement. |
result | Range3d | Preallocated object in which to store result. |
Returns - Range3d
The range encompassing all this channel's displacements scaled by scale
; or a null range if this channel does not contain displacements.
Defined in
- polyface/AuxData.ts Line 166
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.