projectPointToPlane Method
- Return xyz projection of spacePoint to the plane (this Point4d is understood as plane coefficients, not point coordinates)
- If the xyz part of
this
are all zero, (a clone of)spacePoint
is returned.
projectPointToPlane(spacePoint: Point3d, result?: Point3d): Point3d
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | |
result | Point3d |
Returns - Point3d
Defined in
- geometry4d/Point4d.ts Line 380
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.