normalizeXYZW Method
divide all components (x,y,z,w) by the 4d magnitude.
- This is appropriate for normalizing a quaternion
- Use normalizeWeight to divide by the w component.
normalizeXYZW(result?: Point4d): undefined | Point4d
Parameter | Type | Description |
---|---|---|
result | Point4d |
Returns - undefined | Point4d
Defined in
- geometry4d/Point4d.ts Line 519
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.