multiplyPoint3dQuietNormalize Method
multiply matrix * point. This produces a weighted xyzw. Immediately renormalize back to xyz and return (with optional result convention). If zero weight appears in the result (i.e. input is on eyeplane)leave the mapped xyz untouched.
multiplyPoint3dQuietNormalize(point: Readonly<WritableXYAndZ>, result?: Point3d): Point3d
Parameter | Type | Description |
---|---|---|
point | Readonly<WritableXYAndZ> | |
result | Point3d |
Returns - Point3d
Defined in
- geometry4d/Matrix4d.ts Line 500
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.