multiplyPoint3dArrayQuietNormalize Method
multiply each matrix * points[i]. This produces a weighted xyzw. Immediately renormalize back to xyz and replace the original point. If zero weight appears in the result (i.e. input is on eyeplane) leave the mapped xyz untouched.
multiplyPoint3dArrayQuietNormalize(points: Point3d[]): void
Parameter | Type | Description |
---|---|---|
points | Point3d[] |
Returns - void
Defined in
- geometry4d/Matrix4d.ts Line 507
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.