splitPathsByRegionInOnOutXY MethodStatic
Find all intersections among curves in curvesToCut
against the boundaries of region
and return fragments
of curvesToCut
.
- Break
curvesToCut
into parts inside, outside, and coincident.
splitPathsByRegionInOnOutXY(curvesToCut: AnyCurve, region: AnyRegion): { coincidentParts: AnyCurve[], insideParts: AnyCurve[], outsideParts: AnyCurve[] }
@returns output object with all fragments split among insideParts
, outsideParts
, and coincidentParts
Parameter | Type | Description |
---|---|---|
curvesToCut | AnyCurve | |
region | AnyRegion |
Returns - { coincidentParts: AnyCurve[], insideParts: AnyCurve[], outsideParts: AnyCurve[] }
output object with all fragments split among insideParts
, outsideParts
, and coincidentParts
Defined in
- curve/RegionOps.ts Line 532
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.