regionBooleanXY MethodStatic
Return areas defined by a boolean operation.
- If there are multiple regions in loopsA, they are treated as a union.
- If there are multiple regions in loopsB, they are treated as a union.
regionBooleanXY(loopsA: AnyRegion | AnyRegion[], loopsB: AnyRegion | AnyRegion[], operation: RegionBinaryOpType, mergeTolerance: numberGeometry.smallMetricDistance): undefined | AnyRegion
@returns a region resulting from merging input loops and the boolean operation. May contain bridge edges added to connect interior loops to exterior loops.
Parameter | Type | Description |
---|---|---|
loopsA | AnyRegion | AnyRegion[] | first set of loops |
loopsB | AnyRegion | AnyRegion[] | second set of loops |
operation | RegionBinaryOpType | indicates Union, Intersection, Parity, AMinusB, or BMinusA |
mergeTolerance | number | absolute distance tolerance for merging loops |
Returns - undefined | AnyRegion
a region resulting from merging input loops and the boolean operation. May contain bridge edges added to connect interior loops to exterior loops.
Defined in
- curve/RegionOps.ts Line 289
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.