polygonXYAreaIntersectLoopsToPolyface MethodStatic
Return a polyface containing the area intersection of two XY regions.
- Within each region, in and out is determined by parity rules.
- Any face that is an odd number of crossings from the far outside is IN
- Any face that is an even number of crossings from the far outside is OUT
polygonXYAreaIntersectLoopsToPolyface(loopsA: MultiLineStringDataVariant, loopsB: MultiLineStringDataVariant, triangulate: booleanfalse): undefined | Polyface
Parameter | Type | Description |
---|---|---|
loopsA | MultiLineStringDataVariant | first set of loops |
loopsB | MultiLineStringDataVariant | second set of loops |
triangulate | boolean | whether to triangulate the result |
Returns - undefined | Polyface
Defined in
- curve/RegionOps.ts Line 227
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.