polygonBooleanXYToLoops MethodStatic
Return loops of linestrings around areas of a boolean operation between the input regions.
- Each of the two inputs is an array of multiple loops or parity regions.
- Within each of these input arrays, the various entries (loop or set of loops) are interpreted as a union.
- In each "array of loops and parity regions", each entry inputA[i] or inputB[i] is one of:
- A simple loop, e.g. array of Point3d.
- Several simple loops, each of which is an array of Point3d.
polygonBooleanXYToLoops(inputA: MultiLineStringDataVariant[], operation: RegionBinaryOpType, inputB: MultiLineStringDataVariant[]): undefined | AnyRegion
Parameter | Type | Description |
---|---|---|
inputA | MultiLineStringDataVariant[] | first set of loops |
operation | RegionBinaryOpType | indicates Union, Intersection, Parity, AMinusB, or BMinusA |
inputB | MultiLineStringDataVariant[] | second set of loops |
Returns - undefined | AnyRegion
Defined in
- curve/RegionOps.ts Line 357
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.