expandLineStrings MethodStatic
Copy primitive pointers from candidates to result array, replacing each LineString3d by newly constructed instances of LineSegment3d.
expandLineStrings(candidates: CurvePrimitive[]): CurvePrimitive[]
@returns copied (captured) inputs except for the linestrings, which are exploded
Parameter | Type | Description |
---|---|---|
candidates | CurvePrimitive[] | input curves |
Returns - CurvePrimitive[]
copied (captured) inputs except for the linestrings, which are exploded
Defined in
- curve/RegionOps.ts Line 726
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.