constructCurveXYOffset MethodStatic
Construct curves that are offset from a Path or Loop as viewed in xy-plane (ignoring z).
- The construction will remove "some" local effects of features smaller than the offset distance, but will not detect self intersection among widely separated edges.
- Visualization can be found at https://www.itwinjs.org/sandbox/SaeedTorabi/Offset
constructCurveXYOffset(curves: Path | Loop, offsetDistanceOrOptions: number | JointOptions | OffsetOptions): undefined | CurveCollection
Parameter | Type | Description |
---|---|---|
curves | Path | Loop | base curves. |
offsetDistanceOrOptions | number | JointOptions | OffsetOptions | offset distance (positive to left of curve, negative to right) or options object. |
Returns - undefined | CurveCollection
Defined in
- curve/RegionOps.ts Line 411
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.