consolidateAdjacentPrimitives MethodStatic
Look for and simplify:
- Contiguous
LineSegment3d
andLineString3d
objects.- collect all points
- eliminate duplicated points
- eliminate points colinear with surrounding points
- contiguous concentric circular or elliptic arcs
- combine angular ranges
- This function can be used to compress adjacent LineSegment3ds into a LineString3d
consolidateAdjacentPrimitives(curves: CurveCollection, options?: ConsolidateAdjacentCurvePrimitivesOptions): void
Parameter | Type | Description |
---|---|---|
curves | CurveCollection | Path or loop (or larger collection containing paths and loops) to be simplified |
options | ConsolidateAdjacentCurvePrimitivesOptions | options for tolerance and selective simplification. |
Returns - void
Defined in
- curve/RegionOps.ts Line 631
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.