computeXYZWireMomentSums MethodStatic
Return MomentData with the sums of wire moments.
- If
rawMomentData
is the MomentData returned by computeXYAreaMoments, convert to principal axes and moments with callprincipalMomentData = MomentData.inertiaProductsToPrincipalAxes (rawMomentData.origin, rawMomentData.sums);
computeXYZWireMomentSums(root: AnyCurve): undefined | MomentData
Parameter | Type | Description |
---|---|---|
root | AnyCurve | any CurveCollection or CurvePrimitive. |
Returns - undefined | MomentData
Defined in
- curve/RegionOps.ts Line 131
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.