collectCurvePrimitives MethodStatic
Collect all CurvePrimitives
in loosely typed input.
- Always recurses into primitives within explicit collections (Path, Loop, ParityRegion, UnionRegion).
- Optionally recurses into hidden primitives if
smallestPossiblePrimitives
is true.
collectCurvePrimitives(candidates: AnyCurve | AnyCurve[], collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: booleanfalse, explodeLinestrings: booleanfalse): CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
candidates | AnyCurve | AnyCurve[] | input curves |
collectorArray | CurvePrimitive[] | optional pre-defined output array. If defined, it is NOT cleared: primitives are appended. |
smallestPossiblePrimitives | boolean | if true, recurse into the children of a CurveChainWithDistanceIndex. If false, push the CurveChainWithDistanceIndex instead. |
explodeLinestrings | boolean | if true, push a LineSegment3d for each segment of a LineString3d. If false, push the LineString3d instead. |
Returns - CurvePrimitive[]
Defined in
- curve/RegionOps.ts Line 702
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.