collectChains MethodStatic
Restructure curve fragments as Paths and Loops.
collectChains(fragments: AnyCurve[], gapTolerance: numberGeometry.smallMetricDistance): undefined | AnyChain
@returns chains, possibly wrapped in a BagOfCurves.
Parameter | Type | Description |
---|---|---|
fragments | AnyCurve[] | fragments to be chained |
gapTolerance | number | distance to be treated as "effectively zero" when assembling fragments head-to-tail |
Returns - undefined | AnyChain
chains, possibly wrapped in a BagOfCurves.
Defined in
- curve/RegionOps.ts Line 523
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.