cloneCurvesWithXYSplits MethodStatic
Find all intersections among curves in curvesToCut
and cutterCurves
and return fragments of curvesToCut
.
- For a
Loop
,ParityRegion
, orUnionRegion
incurvesToCut
:- if it is never cut by any
cutter
curve, it will be left unchanged. - if cut, the input is downgraded to a set of
Path
curves joining at the cut points.
- if it is never cut by any
- All cutting is "as viewed in the xy plane"
cloneCurvesWithXYSplits(curvesToCut: AnyCurve, cutterCurves: CurveCollection): undefined | AnyCurve
Parameter | Type | Description |
---|---|---|
curvesToCut | AnyCurve | input curves to be fragmented at intersections with cutterCurves |
cutterCurves | CurveCollection | input curves to intersect with curvesToCut |
Returns - undefined | AnyCurve
Defined in
- curve/RegionOps.ts Line 479
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.