chainDistanceToInterpolatedChildFraction Method
Convert distance to local fraction and apply that to interpolate between the stored curve fractions. Note that proportional calculation does NOT account for non-uniform parameterization in the child curve.
chainDistanceToInterpolatedChildFraction(distance: number): number
Parameter | Type | Description |
---|---|---|
distance | number |
Returns - number
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 107
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.