MiteredSweepOptions Interface
Interface bundling options for [CurveFactory.createMiteredSweepSections].
Properties
Name | Type | Description | |
---|---|---|---|
capped | boolean | undefined | Whether to cap the ruled sweep if outputting a ruled sweep or mesh. | |
outputSelect | MiteredSweepOutputSelect | undefined | Whether to output sections only, or sections plus optional geometry constructed from them. | |
strokeOptions | StrokeOptions | undefined | How to stroke the ruled sweep if outputting a mesh. | |
wrapIfPhysicallyClosed | boolean | undefined | Whether first and last planes are averaged and equated when the centerline is physically closed. |
Defined in
- curve/CurveFactory.ts Line 83
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.