createArrayOfLineString3d MethodStatic
Convert variant point data to a single level array of linestrings.
- The result is always an array of LineString3d.
- Single linestring is NOT bubbled out as a special case.
- data with no point is an empty array.
- "deep" data is flattened to a single array of linestrings, losing structure.
createArrayOfLineString3d(data: MultiLineStringDataVariant): LineString3d[]
Parameter | Type | Description |
---|---|---|
data | MultiLineStringDataVariant |
Returns - LineString3d[]
Defined in
- curve/LineString3d.ts Line 1385
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.