collectCurvePrimitivesGo Method
Return an array containing only the curve primitives.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], _smallestPossiblePrimitives: boolean, explodeLinestrings: booleanfalse): void
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | array to receive primitives (pushed -- the array is not cleared) |
_smallestPossiblePrimitives | boolean | unused |
explodeLinestrings | boolean | if true, push a LineSegment3d for each segment. If false, only push this . |
Returns - void
Defined in
- curve/LineString3d.ts Line 1402
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.