quickLength MethodAbstract
Compute a length for curve which may be a fast approximation to the true length. This is expected to be either (a) exact or (b) larger than the actual length, but by no more than a small multiple, perhaps up to PI/2, but commonly much closer to 1.
- An example use of this is for setting a tolerance which is a small multiple of the curve length.
- Simple line, circular arc, and transition spiral may return exact length
- Ellipse may return circumference of some circle or polygon that encloses the ellipse.
- bspline curve may return control polygon length
quickLength(): number
Returns - number
Defined in
- curve/CurvePrimitive.ts Line 527
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.