getFractionToDistanceScale Method
If the curve primitive has distance-along-curve strictly proportional to curve fraction, return the scale factor. If distance-along-the-curve is not proportional, return undefined.
- When defined, the scale factor is always the length of the curve.
- This scale factor is typically available for these curve types:
- All
LineSegment3d
- All
- Arc3d which is a true circular arc (axes perpendicular and of equal length).
- CurveChainWithDistanceIndex
- This scale factor is undefined for these curve types:
- Arc3d which is a true ellipse, i.e. unequal lengths of defining vectors or non-perpendicular defining vectors.
- bspline and bezier curves
getFractionToDistanceScale(): undefined | number
@returns scale factor or undefined
Returns - undefined | number
scale factor or undefined
Defined in
- curve/CurvePrimitive.ts Line 581
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.