fractionToSignedXYRadiusOfCurvature Method
Construct signed distance from a point on the planar curve to its center of curvature (in xy only).
- Positive distance means the center is to the left of the curve at fraction.
- Negative distance means the center is to the right of the curve at fraction.
- Zero distance means curve is linear at fraction.
fractionToSignedXYRadiusOfCurvature(fraction: number): number
Parameter | Type | Description |
---|---|---|
fraction | number |
Returns - number
Defined in
- curve/CurvePrimitive.ts Line 205
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.