createSingleOffsetPrimitiveXY MethodStatic
Create the offset of a single curve primitive as viewed in the xy-plane (ignoring z).
createSingleOffsetPrimitiveXY(curve: CurvePrimitive, offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
curve | CurvePrimitive | primitive to offset |
offsetDistanceOrOptions | number | OffsetOptions | offset distance (positive to left of curve, negative to right) or options object |
Returns - undefined | CurvePrimitive | CurvePrimitive[]
Defined in
- curve/CurveOps.ts Line 122
Last Updated: 13 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.