constructCurveXYOffset MethodStatic

Construct curves that are offset from a Path or Loop as viewed in xy-plane (ignoring z).

  • The construction will remove "some" local effects of features smaller than the offset distance, but will not detect self intersection among widely separated edges.

constructCurveXYOffset(curves: Path | Loop, offsetDistanceOrOptions: number | OffsetOptions): undefined | CurveCollection

Parameter Type Description
curves Path | Loop base curves.
offsetDistanceOrOptions number | OffsetOptions offset distance (positive to left of curve, negative to right) or options object.

Returns - undefined | CurveCollection

Defined in

Last Updated: 13 November, 2024