collectChainsAsLineString3d MethodStatic

Restructure curve fragments, to be stroked and passed into the callback.

  • Chain formation is dependent upon input fragment order, as a greedy algorithm is employed.

collectChainsAsLineString3d(fragments: AnyCurve[], announceChain: (chainPoints: LineString3d) => void, strokeOptions?: StrokeOptions, gapTolerance: numberGeometry.smallMetricDistance, _planeTolerance?: number): void

Parameter Type Description
fragments AnyCurve[] fragments to be chained and stroked
announceChain (chainPoints: LineString3d) => void callback to process each stroked Path and Loop
strokeOptions StrokeOptions options for stroking the chains
gapTolerance number distance to be treated as "effectively zero" when assembling fragments head-to-tail. Also used for removing duplicate points in the stroked chains.
_planeTolerance number unused, pass undefined

Returns - void

Defined in

Last Updated: 13 November, 2024