createArcPointTangentRadius MethodStatic
Create a circular arc from start point, tangent at start, radius, optional plane normal, arc sweep.
- The vector from start point to center is in the direction of upVector crossed with tangentA.
createArcPointTangentRadius(start: Point3d, tangentAtStart: Vector3d, radius: number, upVector?: Vector3d, sweep?: Angle | AngleSweep): undefined | Arc3d
Parameter | Type | Description |
---|---|---|
start | Point3d | start point. |
tangentAtStart | Vector3d | vector in tangent direction at the start. |
radius | number | signed radius. |
upVector | Vector3d | optional out-of-plane vector. Defaults to positive Z. |
sweep | Angle | AngleSweep | angular range. If single Angle is given, start angle is at 0 degrees (the start point). |
Returns - undefined | Arc3d
Defined in
- curve/CurveFactory.ts Line 458
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.