collectCurvePrimitives Method
Return an array containing all CurvePrimitives in the instance.
- This method is recursive. For example, if the CurveCollection contains a Loop, all CurvePrimitives of the Loop are pushed onto the returned array.
collectCurvePrimitives(collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: booleanfalse, explodeLineStrings: booleanfalse): CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | optional array to receive primitives. If present, new primitives are ADDED (without clearing the array). |
smallestPossiblePrimitives | boolean | if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children. |
explodeLineStrings | boolean |
Returns - CurvePrimitive[]
Defined in
- curve/CurveCollection.ts Line 147
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.