collectCurvePrimitivesGo Method
Return an array containing only the curve primitives.
collectCurvePrimitivesGo(collectorArray: CurvePrimitive[], smallestPossiblePrimitives: booleanfalse, explodeLineStrings: booleanfalse): void
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | array to receive primitives (pushed -- the array is not cleared) |
smallestPossiblePrimitives | boolean | if true, recurse on the children. If false, only push this . |
explodeLineStrings | boolean |
Returns - void
Defined in
- curve/CurveChainWithDistanceIndex.ts Line 413
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.