ArcVectors Interface
Compact vector form of an elliptic arc defined by center, vectors at 0 and 90 degrees, and angular sweep. *
@see Curve Collections learning article for further details of the parameterization and meaning of the vectors.
Properties
Name | Type | Description | |
---|---|---|---|
center | Point3d | Center point of arc. | |
sweep | AngleSweep | Angular range swept by the arc, of length less than 2*pi if not a full ellipse. | |
vector0 | Vector3d | Vector from the arc center to the arc point at parameter 0 degrees. | |
vector90 | Vector3d | Vector from the arc center to the arc point at parameter 90 degrees. |
Defined in
- curve/Arc3d.ts Line 49
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.