radiansToRotatedBasis Method
Return a parametric plane with
- origin at arc center
- vectorU from center to arc at angle (in radians)
- vectorV from center to arc at 90 degrees past the angle.
radiansToRotatedBasis(radians: number, result?: Plane3dByOriginAndVectors): Plane3dByOriginAndVectors
Parameter | Type | Description |
---|---|---|
radians | number | angular position |
result | Plane3dByOriginAndVectors | optional preallocated plane |
Returns - Plane3dByOriginAndVectors
Defined in
- curve/Arc3d.ts Line 655
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.