create MethodStatic
Create an arc by center with vectors to points at 0 and 90 degrees in parameter space.
create(center: Point3d, vector0: Vector3d, vector90: Vector3d, sweep?: AngleSweep, result?: Arc3d): Arc3d
Parameter | Type | Description |
---|---|---|
center | Point3d | arc center |
vector0 | Vector3d | vector to 0 degrees (commonly major axis) |
vector90 | Vector3d | vector to 90 degree point (commonly minor axis) |
sweep | AngleSweep | sweep limits (default full sweep) |
result | Arc3d | optional preallocated result |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 373
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.