createStartMiddleEnd MethodStatic
Create an elliptical arc from three points on the ellipse: two points on an axis and one in between.
createStartMiddleEnd(start: Readonly<WritableXYAndZ>, middle: Readonly<WritableXYAndZ>, end: Readonly<WritableXYAndZ>, sweep?: AngleSweep, result?: Arc3d): undefined | Arc3d
@returns elliptical arc, or undefined if construction impossible.
Parameter | Type | Description |
---|---|---|
start | Readonly<WritableXYAndZ> | start of arc, on an axis. |
middle | Readonly<WritableXYAndZ> | point on arc somewhere between start and end . |
end | Readonly<WritableXYAndZ> | point on arc directly opposite start . |
sweep | AngleSweep | angular sweep, measured from start in the direction of middle .For a half-ellipse from start to end passing through middle , pass AngleSweep.createStartEndDegrees(0,180) .Default value is full sweep to create the entire ellipse. |
result | Arc3d | optional preallocated result. |
Returns - undefined | Arc3d
elliptical arc, or undefined if construction impossible.
Defined in
- curve/Arc3d.ts Line 395
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.