createFilletArc MethodStatic
Determine an arc "at a point of inflection" of a point sequence.
- Return the arc along with the fractional positions of the tangency points.
- In the returned object:
arc
is the (bounded) arc.fraction10
is the tangency point's position as an interpolating fraction of the line segment frompoint1
(backwards) topoint0
.fraction12
is the tangency point's position as an interpolating fraction of the line segment frompoint1
(forward) topoint2
.point
is thepoint1
input.
- If unable to construct the arc:
point
is thepoint1
input.- both fractions are zero.
arc
is undefined.
createFilletArc(point0: Point3d, point1: Point3d, point2: Point3d, radius: number): ArcBlendData
Parameter | Type | Description |
---|---|---|
point0 | Point3d | first point of path (the point before the point of inflection). |
point1 | Point3d | second point of path (the point of inflection). |
point2 | Point3d | third point of path (the point after the point of inflection). |
radius | number | arc radius. |
Returns - ArcBlendData
Defined in
- curve/Arc3d.ts Line 1284
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.