createCircularStartMiddleEnd MethodStatic
Create a circular arc defined by start point, any intermediate point, and end point. If the points are colinear, assemble them into a linestring.
createCircularStartMiddleEnd(pointA: Readonly<WritableXYAndZ>, pointB: Readonly<WritableXYAndZ>, pointC: Readonly<WritableXYAndZ>, result?: Arc3d): LineString3d | Arc3d
Parameter | Type | Description |
---|---|---|
pointA | Readonly<WritableXYAndZ> | |
pointB | Readonly<WritableXYAndZ> | |
pointC | Readonly<WritableXYAndZ> | |
result | Arc3d |
Returns - LineString3d | Arc3d
Defined in
- curve/Arc3d.ts Line 531
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.