createCircularStartEndRadius MethodStatic
Create a circular arc defined by start and end points and radius.
createCircularStartEndRadius(start: Point3d, end: Point3d, radius: number, helper: Point3d | Vector3d): undefined | Arc3d
@returns the constructed arc, or undefined if desired arc cannot be constructed
Parameter | Type | Description |
---|---|---|
start | Point3d | start point of the arc |
end | Point3d | end point of the arc |
radius | number | |
helper | Point3d | Vector3d | a third point near the arc in its plane, or a vector in the direction of the arc normal |
Returns - undefined | Arc3d
the constructed arc, or undefined if desired arc cannot be constructed
Defined in
- curve/Arc3d.ts Line 456
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.