constructOffsetXY Method
Construct an offset of the instance curve as viewed in the xy-plane (ignoring z).
constructOffsetXY(offsetDistanceOrOptions: number | OffsetOptions): undefined | CurvePrimitive | CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
offsetDistanceOrOptions | number | OffsetOptions | offset distance (positive to left of the instance curve), or options object |
Returns - undefined | CurvePrimitive | CurvePrimitive[]
Defined in
- curve/Arc3d.ts Line 1309
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.