cloneInRotatedBasis Method
Return an arc whose basis vectors are rotated by given angle within the current basis space.
- the result arc will have its zero-degree point (new
vector0
) at the currentvector0 * cos(theta) + vector90 * sin(theta)
- the result sweep is adjusted so all fractional coordinates (e.g. start and end) evaluate to the same xyz.
- Specifically, theta is subtracted from the original start and end angles.
cloneInRotatedBasis(theta: Angle): Arc3d
Parameter | Type | Description |
---|---|---|
theta | Angle | the angle (in the input arc space) which is to become the 0-degree point in the new arc. |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 1202
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.