cloneAtZ Method
Return a clone of this arc, projected to given z value.
- If
z
is omitted, the clone is at the z of the center. - This function projects the arc into a plane parallel to xy-plane.
- Note that projection to fixed z can change circle into ellipse (and (rarely) ellipse to circle)
cloneAtZ(z?: number): Arc3d
Parameter | Type | Description |
---|---|---|
z | number |
Returns - Arc3d
Defined in
- curve/Arc3d.ts Line 489
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.