allPerpendicularAngles Method
Return all radian angles where the ellipse tangent is perpendicular to the vector to a spacePoint.
allPerpendicularAngles(spacePoint: Point3d, _extend: booleantrue, endpoints: booleanfalse): number[]
Parameter | Type | Description |
---|---|---|
spacePoint | Point3d | point of origin of vectors to the ellipse |
_extend | boolean | always true. Sweep is ignored: perpendiculars for the full ellipse are returned. |
endpoints | boolean | if true, force the end radians into the result. |
Returns - number[]
Defined in
- curve/Arc3d.ts Line 793
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.