setFrom Method
Set the x,y,z parts from one of these input types
- XYZ -- copy the x,y,z parts
- Float64Array -- Copy from indices 0,1,2 to x,y,z
- XY -- copy the x, y parts and set z=0
setFrom(other: Float64Array | Readonly<WritableXAndY> | Readonly<WritableXYAndZ>): void
Parameter | Type | Description |
---|---|---|
other | Float64Array | Readonly<WritableXAndY> | Readonly<WritableXYAndZ> |
Returns - void
Defined in
- geometry3d/Point3dVector3d.ts Line 119
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.