isAlmostEqualPointPlusScaledVector Method
Return true if this and {other + vector*scale} have equal x,y,z parts within Geometry.smallMetricDistance.
- this method is useful in testing "point on ray" without explicitly constructing the projection point
isAlmostEqualPointPlusScaledVector(other: Readonly<WritableXYAndZ>, vector: Readonly<WritableXYAndZ>, scale: number, tol?: number): boolean
Parameter | Type | Description |
---|---|---|
other | Readonly<WritableXYAndZ> | |
vector | Readonly<WritableXYAndZ> | |
scale | number | |
tol | number |
Returns - boolean
Defined in
- geometry3d/Point3dVector3d.ts Line 178
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.