isAlmostEqual Method
Returns true if this and other have equal x,y,z parts within Geometry.smallMetricDistance.
isAlmostEqual(other: Readonly<Readonly<WritableXYAndZ>>, tol?: number): boolean
Parameter | Type | Description |
---|---|---|
other | Readonly<Readonly<WritableXYAndZ>> | The other XYAndZ to compare |
tol | number | The tolerance for the comparison. If undefined, use smallMetricDistance |
Returns - boolean
Defined in
- geometry3d/Point3dVector3d.ts Line 165
Last Updated: 28 October, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.