tryNormalizeInPlace Method
Try to normalize (divide by magnitude), storing the result in place.
tryNormalizeInPlace(smallestMagnitude: numberGeometry.smallFraction): boolean
@returns false if magnitude is too small. In this case the vector is unchanged.
Parameter | Type | Description |
---|---|---|
smallestMagnitude | number | smallest magnitude allowed as divisor. |
Returns - boolean
false if magnitude is too small. In this case the vector is unchanged.
Defined in
- geometry3d/Point3dVector3d.ts Line 1284
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.