scaleToLength Method
Return a vector in the direction of this
but with specified length.
scaleToLength(length: number, result?: Vector3d): undefined | Vector3d
@returns scaled instance vector, or undefined if the instance magnitude is too small
Parameter | Type | Description |
---|---|---|
length | number | desired length of vector |
result | Vector3d | optional preallocated result to populate and return |
Returns - undefined | Vector3d
scaled instance vector, or undefined if the instance magnitude is too small
Defined in
- geometry3d/Point3dVector3d.ts Line 1231
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.