createRotateVectorAroundVector MethodStatic
Return a vector which is the input vector
rotated by angle
around the axis
vector.
createRotateVectorAroundVector(vector: Vector3d, axis: Vector3d, angle?: Angle): undefined | Vector3d
@returns undefined if axis has no length.
Parameter | Type | Description |
---|---|---|
vector | Vector3d | initial vector. |
axis | Vector3d | axis of rotation. |
angle | Angle | angle of rotation. If undefined, 90 degrees is implied. |
Returns - undefined | Vector3d
undefined if axis has no length.
Defined in
- geometry3d/Point3dVector3d.ts Line 884
Last Updated: 14 November, 2024
Found something wrong, missing, or unclear on this page?Raise an issue in our repo.